Degraded performance on Public REST API service
Incident Report for Crossref
Resolved
This incident has been resolved.
Posted Jun 20, 2024 - 21:24 UTC
Update
We've written a blog post about optimising the public REST API's performance in the immediate term. Please check it out at https://0-www-crossref-org.pugwash.lib.warwick.ac.uk/blog/rebalancing-our-rest-api-traffic. We're keeping this incident open while we make these changes.
-GH
Posted Jun 04, 2024 - 22:04 UTC
Update
We are continuing to monitor for any further issues.
Posted Jun 03, 2024 - 14:44 UTC
Update
We are continuing to monitor through the weekend for further issues regarding degraded performance of our Public REST API. - KL
Posted May 31, 2024 - 14:16 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 29, 2024 - 19:59 UTC
Investigating
We are experiencing degraded performance on our Public REST API, and our team is investigating.

If you are having problems, we would recommend using the Polite REST API if possible - more details here: https://github.com/CrossRef/rest-api-doc#good-manners--more-reliable-service
Posted May 29, 2024 - 08:58 UTC
This incident affected: APIs (Public REST API).