Unplanned maintenance: updating to haproxy 2.2 and TLS 1.2
Incident Report for Crossref
Resolved
This incident has been resolved.
Posted Feb 04, 2021 - 16:52 UTC
Investigating
We found some problems with our last update to haproxy 2.2 and TLS 1.2 earlier this week, and rolled back the previous release (https://0-status-crossref-org.pugwash.lib.warwick.ac.uk/incidents/ftwpm7ztg9n3). We will be undergoing unplanned maintenance today, Wednesday, 3 February, from 2300 to 0100 (4 February) UTC to update to haproxy 2.2 and TLS 1.2. Users may experience intermittent outages during this time. As a reminder, this update will strengthen the security of our web servers, and will again result in disabling TLS versions 1.0 and 1.1.
Posted Feb 03, 2021 - 19:17 UTC
This incident affected: APIs (Public REST API, Polite REST API, OAI-PMH, XML API, Event Data Query API, OpenURL, Crossmark dialog server, Public content negotiation), Meta (deliberately-unreliable server), Metadata Plus (Plus REST API, Plus OAI-PMH, XML Snapshots, JSON Snapshots), Content Registration (Admin tool, Test admin tool), Sites (Metadata search, Participation reports), and Beta (Metadata Manager).